Lightbox w/video

Comments

4 comments

  • doug asherman

    If it helps, here is the generated HTML:

    <a class="uikit-lightbox uk-inline uk-link-muted" href="" data-caption="" data-type="iframe">

            <div class="full-image" hidden="">

                <!--start of UIKit Video stack-->

    <!--youtube-->

    <iframe id="" class="uk-responsive-width" src="https://www.youtube-nocookie.com/embed/ynFNt4tgBJ0?autoplay=0;showinfo=0;rel=0;modestbranding=1;playsinline=1&amp;enablejsapi=1" frameborder="0" allowfullscreen="" uk-responsive="" uk-video="autoplay: true; automute: true;"></iframe>

    <!--vimeo-->

    <!--html5-->

    <!--html5-->

    <!--end of UIKit Video stack-->   

            </div>

                <!--start of UIKit button stack-->

        <button id="" class="uk-button  uk-button-default     " type="button" href="#" target="" rel="">Button</button>

    <!--end of UIkit button stack-->

        </a>

    0
    Comment actions Permalink
  • Lucas Tsolakian

    Hi Dough, did you tried the Video and Lightbox examples of the Tests project that came in the package? Cannot reproduce an error here. Will test with your own YouTube video and let you know. 

    0
    Comment actions Permalink
  • Lucas Tsolakian

    Dough I cannot see an issue, here's step by step:

    • Drop a Lightbox stack in the page and set the type to iframe
    • Remove the Image from the Lightbox and drop a Video stack in there
    • Enter the ID of your video in the Video stack
    • Lastly drop a Button in the trigger area of the Lightbox stack and set the integration to lightbox and video

     

     

     

    -1
    Comment actions Permalink
  • doug asherman

    Thank you Lucas.

    I don't know which of those steps I wasn't following before, but it works correctly now. I think I wasn't setting the type to iframe.

    Thanks again. I am really enjoying learning all of the features of Ulkit.

     

    Doug

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk